Округление времени в excel до минут. Как округлить столбец времени в Excel с точностью до 15 минут?

Как в Excel округлить время?

Время в Excel записывается в виде толики суток и выводится в ячейку в согласовании с данным форматом.

Ячейка с округлённым значением времени тоже обязана иметь формат времени.

чтобы округлить время нужно пользоваться функцией ОКРУГЛ (ОКРУГЛВВЕРХ/ОКРУГЛВ­НИЗ).

Время нужно поделить на точность округления, выраженную в сутках, округлить до целых и итог умножить на точность округления.

в сутках 24 часа либо 24*60=1440 минут

если время в ячейке A2, а точность округления в ячейке E2,то округлённое время выразится формулами:

=ОКРУГЛ( A2*1440/E2 ; 0 )*E2/1440

=ОКРУГЛВВЕРХ( A2*1440/E2 ; 0 )*E2/1440

=ОКРУГЛВНИЗ( A2*1440/E2 ; 0 )*E2/1440

Округление времени в excel до минут. Как округлить столбец времени в Excel с точностью до 15 минут?

Формулы для округления времени:

округление до минут (точность 1 минута)

=ОКРУГЛ( A2*1440 ; 0)/1440

=ОКРУГЛВВЕРХ( A2*1440 ;0)/1440

=ОКРУГЛВНИЗ( A2*1440 ;0)/1440

округление до 5 минут (точность 5 минут)

=ОКРУГЛ( A2*1440/5 ; 0 )*5/1440

=ОКРУГЛВВЕРХ( A2*1440/5 ; 0 )*5/1440

=ОКРУГЛВНИЗ( A2*1440/5 ; 0 )*5/1440

округление до 15 минут (точность 15 минут)

=ОКРУГЛ( A2*1440/15 ; 0 )*15/1440

=ОКРУГЛВВЕРХ( A2*1440/15 ; 0 )*15/1440

=ОКРУГЛВНИЗ( A2*1440/15 ; 0 )*15/1440

округление до 30 минут (точность 30 минут)

=ОКРУГЛ( A2*1440/30 ; 0 )*30/1440

=ОКРУГЛВВЕРХ( A2*1440/30 ; 0 )*30/1440

=ОКРУГЛВНИЗ( A2*1440/30 ; 0 )*30/1440

округление до 5 секунд (точность 5/60=0.0833333333333­333 минут)

=ОКРУГЛ( A2*1440/0.0833333333­333333 ; 0 )*0.0833333333333333­/1440

=ОКРУГЛВВЕРХ( A2*1440/0.0833333333­333333 ; 0 )*0.0833333333333333­/1440

=ОКРУГЛВНИЗ( A2*1440/0.0833333333­333333 ; 0 )*0.0833333333333333­/1440

округление до 15 секунд (точность 0.25 минут)

=ОКРУГЛ( A2*1440/0.25 ; 0 )*0.25/1440

=ОКРУГЛВВЕРХ( A2*1440/0.25 ; 0 )*0.25/1440

=ОКРУГЛВНИЗ( A2*1440/0.25 ; 0 )*0.25/1440

округление до 30 секунд (точность 0.5 минут)

=ОКРУГЛ( A2*1440/0.5 ; 0 )*0.5/1440

=ОКРУГЛВВЕРХ( A2*1440/0.5 ; 0 )*0.5/1440

=ОКРУГЛВНИЗ( A2*1440/0.5 ; 0 )*0.5/1440

округление до часов (точность 60 минут)

=ОКРУГЛ( A2*1440/60 ; 0 )*60/1440

=ОКРУГЛВВЕРХ( A2*1440/60 ; 0 )*60/1440

=ОКРУГЛВНИЗ( A2*1440/60 ; 0 )*60/1440

Сложение и вычитание значений времени

Допустим, для вас необходимо сложить два различных значения времени, чтоб получить результат. Не считая того, нужно вычесть одно значение времени из другого, чтоб получить общее время, затраченное на работу над проектом.

Как видно из приведенных ниже разделов, приложение Excel упрощает сложение и вычитание значений времени.

Сложение значений времени

Допустим, для вас необходимо выяснить, сколько часов и минут востребует выполнение 2-ух задач. По вашей оценке на выполнение первой задачки будет нужно 6 часов 45 минут, а на выполнение 2-ой задачи — 9 часов 30 минут.

Читайте также  Программы для отображения FPS в играх

Вот один из методов опции на листе.

  1. Введите 6:45 в ячейку B2и введите 9: 30 в ячейку B3.

  2. В ячейке B4 введите = B2 + B3 и нажмите кнопку ВВОД.

    Округление времени в excel до минут. Как округлить столбец времени в Excel с точностью до 15 минут?

    Результат: 16 – 16 часов и 15 минут — для выполнения 2-ух задач.

    Совет: Вы сможете также ложить значения времени с помощью функции Автосумма для чисел. Выделите ячейку B4, а потом на вкладке Главная выберите Автосумма. Формула будет смотреться последующим образом: =СУММ(B2:B3). Нажмите кнопку ВВОД, чтоб получить тот же итог, 16 часов и 15 минут.

И это было довольно просто, но ежели вы желаете, чтоб часы не превосходили 24, вы сможете выполнить доп деяния. Для результатов формулы нужно применить особый формат.

Чтобы добавить наиболее 24 часов, выполните указанные ниже действия.

  1. В ячейку B2 введите значение 12:45, а в ячейку B3 — 15:30.

  2. В ячейку B4 введите формулу =B2+B3 и нажмите кнопку ВВОД.

    Округление времени в excel до минут. Как округлить столбец времени в Excel с точностью до 15 минут?

    Результат — 4:15, что не может быть ожидаемым. Это соединено с тем, что время для задачки 2 — 24-часовой формат времени. 15:30 совпадает с 3:30.

  3. Чтобы показать значение времени, превышающее 24 часа, выберите ячейку B4.

  4. На вкладке Главная в группе Ячейки нажмите клавишу Формат и выберите пункт Формат ячеек.

    Округление времени в excel до минут. Как округлить столбец времени в Excel с точностью до 15 минут?

  5. В диалоговом окне Формат ячеек в перечне Категория выберите пункт (все форматы).

  6. В поле тип вверху перечня форматов введите [h]: mm; @ и нажмите клавишу ОК.

    Проведите заметку двоеточия опосля [h] и точку с запятой опосля мм.

В итоге получится 28 часов 15 минут. Формат сохраняется в перечне Тип для предстоящего использования.

Вычитание значений времени

Вот еще один пример: Представим, что ты и ваши друзья знают время начала и окончания в проекте “добровольный” и желали бы выяснить, сколько времени затрачено на общий доступ.

Читайте также  Как посмотреть сколько символов в ворде. Как посчитать количество символов в Ворде

Выполните указанные ниже деяния, чтоб получить затраченное время (разница меж 2-мя значениями времени).

  1. В ячейке B2 введите время начала и включите “a” для AM либо “p” для PM. Опосля этого нажмите кнопку ВВОД.

  2. В ячейке C2 введите время окончания, к примеру “a” либо “p“, а потом нажмите кнопку ВВОД.

  3. Введите остальные значениям времени начала и окончания для собственных друзей Сергея и Николая.

  4. В ячейке D2 для вычитания времени окончания из времени начала введите формулу = C2-B2и нажмите кнопку ВВОД.

    Округление времени в excel до минут. Как округлить столбец времени в Excel с точностью до 15 минут?

  5. В диалоговом окне Формат ячеек в перечне Категория выберите пункт (все форматы).

  6. Выберите в перечне Тип пункт ч:мм (часы и минуты) и нажмите клавишу ОК.

    Теперь видно, что Григорий работал 3 часа 45 минут.

    Округление времени в excel до минут. Как округлить столбец времени в Excel с точностью до 15 минут?

  7. Чтобы получить результаты для Сергея и Николая, скопируйте формулу, выделив ячейку D2 и перетащив ее на ячейку D4.

    Параметры форматирования в ячейке D2 скопируются вкупе с формулой.

Чтобы вычесть время, которое превосходит 24 часа, выполните указанные ниже действия.

Для вычитания различия меж 2-мя значениями времени, превосходящими 24 часа, нужно сделать формулу.

Выполните указанные ниже действия.

  1. В примере выше щелкните ячейку B1 и перетащите рамку выделения на ячейку B2, что даст для вас возможность применить формат к двум ячейкам одновременно.

  2. В диалоговом окне Формат ячеек в перечне Категория выберите пункт (все форматы).

  3. В поле Тип вверху перечня форматов введите д.м.гггг ч:мм.

    Обратите внимание на пустое место в конце гггг и в конце мм.

    В предстоящем новейший формат будет доступен в перечне Тип.

  4. В ячейке B1 введите дату начала, включая день, месяцигод.

    Округление времени в excel до минут. Как округлить столбец времени в Excel с точностью до 15 минут?

  5. Выполните те же деяния для даты окончания в ячейке B2.

  6. Введите формулу в ячейку B3: =(B2-B1)*24.

Результат — 31,5 часа.

Примечание: В Excel в Вебе можно добавлять и вычитать наиболее 24 часов, но нельзя использовать пользовательские числовые форматы.

Сложение значений времени

Допустим, необходимо выяснить, сколько часов и минут востребует выполнение 2-ух задач. По вашей оценке на выполнение первой задачки будет нужно 6 часов 45 минут, а на выполнение 2-ой задачи — 9 часов 30 минут.

  1. В ячейку B2 введите значение 6:45, а в ячейку B3 — 9:30.

  2. В ячейку B4 введите формулу =B2+B3 и нажмите кнопку ВВОД.

Читайте также  Прошивка prestigio geovision 5200bt. Обновление Навител Навигатор 9.1 для 520 моделей автонавигаторов

Округление времени в excel до минут. Как округлить столбец времени в Excel с точностью до 15 минут?

На выполнение 2-ух задач будет нужно 16 часов 15 минут.

Совет: Вы также сможете добавить время с помощью автосуммирования. Щелкните в ячейке B4. Потом щелкните главная > Автосумма. Формула будет смотреться последующим образом: =СУММ(B2:B3). Нажмите кнопку ВВОД, чтоб получить результат: 16 часов и 15 минут.

Вычитание значений времени

Предположим, вы с друзьями понимаете время начала и окончания работы над волонтерским проектом и желаете выяснить, сколько времени вы издержали. Иными словами, вы желаете вычислить затраченное время либо разницу меж 2-мя значениями времени.

  1. В ячейку B2 введите время начала, нажмите кнопку ПРОБЕЛ, а потом введите (для 12-часового формата времени) буковку “a” для AM либо “p” для PM и нажмите кнопку ВВОД. В ячейку C2 введите время окончания, включая подобающую буковку (для 12-часового формата времени) “a” либо “p”, и нажмите кнопку ВВОД. Введите остальные значения времени начала и окончания для собственных друзей Владимира и Николая.

  2. В ячейку D2 введите формулу =C2-B2, чтоб вычесть значение времени окончания из значения времени начала, и нажмите кнопку ВВОД.

Округление времени в excel до минут. Как округлить столбец времени в Excel с точностью до 15 минут?

Теперь мы лицезреем, что Григорий проработал в рамках проекта 3 часа 45 минут.

  1. Чтобы получить результаты для Владимира и Николая, скопируйте формулу, щелкнув ячейку D2 и перетащив рамку выделения на ячейку D4. Характеристики форматирования в ячейке D2 скопируются вкупе с формулой.

Округление времени в excel до минут. Как округлить столбец времени в Excel с точностью до 15 минут?

Примечание:  Эта страничка переведена автоматом, потому ее текст может содержать некорректности и грамматические ошибки. Для нас принципиально, чтоб эта статья была для вас полезна. Была ли информация полезной? Для удобства также приводим ссылку на оригинал (на британском языке).

Оставьте комментарий